TaxCycle Home | Products | Pricing | Events | Documentation | Support | Blog

Error re S546 (postal code length)


#1

I am doing a T2 and experienced a new error which appears to be incorrect. It says the “Postal code on line 280 in Schedule 546 must not exceed 6 characters”.

The schedule 546 is picking up the postal code from the postal cost field in the Address section of the “Info” screen (and is not over-ridden). I assume it’s because the space, which is formatted by the program, adds another “character”?

Unfortunately it’s not an error code that you can check off.


#2

This happens to me about 30~50% of the time Kevin. For me, I feel the issue likely results because all carryforwards to date have rolled forward from 2015 Profile T2 returns.

The fix for me has always been to go to the client’s “info” screen and under Address - Head Office, retype the postal code in that field without any spaces (Taxcycle inserts the space itself). Try that and see if it fixes your diagnostic issue on the Schedule 546.


#3

I doubt that it’s a new issue. So, @snoplowguy you say this happens when you carryforward (CFWD) from a ProFile T2 file. @Kevin Is this the same case for you? In any case, could you both send us the ProFile files so we can try it and fix it? If this is happening from TaxCycle to TaxCycle CFWD, I would appreciate the TaxCycle file so I can try the CFWD.
(I will send you an email from ecourier so you can attach the files and send them to us)

In TaxCycle, I am able to reproduce it by doing the following:
In Info, in the postal code field in the head office section, press Control + F2 to do a format override then enter a valid postal code (ie. T2E 1A7). Then, in S546, on line 280, I can see the review message.

The workaround is to remove the format override in Info postal code field (ie. Control + F2) then re-enter the postal code.

Steven


#4

Thanks Wayne. I haven’t seen this error up until today. The S546 postal code field looks fine so I can’t imagine the Ontario Ministry having problems with it as is. The error code didn’t interfere or prevent printing so it shouldn’t be too much of an issue. Thanks for letting me know that it’s happening elsewhere.


#5

After reading @Steven’s comment, I see that for me simply hitting the “F2” key to “remove override” in the Postal Code field in the Info Screen in the Head Office section fixes it without having to retype the postal code.


#6

@snoplowguy

Thanks for the file. I confirm that I can reproduce. We will look into it and get it fixed.

Steven


#7

Hi Steven. I just sent you the file. The F2 thing didn’t work on my file.


#8

@kevin
Got it. We will investigate and fix it for the next release.
Thank you for the files!

Steven